lapack.dll/rlapack.dll problem

Jun 22, 2011 at 2:52 PM

Hi, thanks very much for the wonderful package!

I tried to run the following:

GenericVector

testResult = engine.EagerEvaluate("summary(lm(A[,5]~A[,2]+A[,3]+A[,4]+A[,1]))").AsList();

and I got the following error:

RNET.vshost.exe error
The program can't start because Rlapack is missing from your computer.  Try reinstalling this program to fix the problem.

Error in chol2inv(Qr$qr[p1, p1, drop = FALSE]) :
  lapack routines cannot be loaded
In addition: Warning message:
In chol2inv(Qr$qr[p1, p1, drop = FALSE]) :
  unable to load shared object 'C:/Program Files/R/R-2.12.1/modules/i386/lapack.
dll':
  LoadLibrary failure:  The specified module could not be found.

If I take out "summary", the line runs perfectly.  Do you know what's the problem here?  Thanks.

Mar 12, 2012 at 6:23 PM
Edited Mar 13, 2012 at 7:40 PM

Hello,

Yes, I'm having the same problem! 

Well, I'm not using the "summary" function, I'm using a different function, but receiving the same error message.

fxdeveloper, did you or anyone else find a solution to this problem? 

Thank you!!!

Found a few different discussion about this topic (http://rdotnet.codeplex.com/discussions/243243 & http://stackoverflow.com/questions/7960738/importing-mgcv-fails-because-rlapack-dll-cannot-be-found), not all the solutions work in my case. Hopefully, this will help others that run into this problem.

The solution that I found that worked came from http://stackoverflow.com/questions/7960738/importing-mgcv-fails-because-rlapack-dll-cannot-be-found:

string rhome = System.Environment.GetEnvironmentVariable("R_HOME");
if (string.IsNullOrEmpty(rhome))
    rhome = @"C:\Program Files\R\R-2.14.0";

System.Environment.SetEnvironmentVariable("R_HOME", rhome);
System.Environment.SetEnvironmentVariable("PATH", System.Environment.GetEnvironmentVariable("PATH") + ";" + rhome + @"\bin\i386");

Hopefully, this will help others...

Jul 11, 2012 at 5:22 AM

I try this solution,but still have the problem.anyone know why?

Jul 12, 2012 at 2:39 AM
Edited Jul 12, 2012 at 2:39 AM

Please Set the environment path like:D:\Program Files\R\R-2.15.0\bin\i386.

and import RESTART you computer.

It may be help you.