Which version of R is currently supported

Nov 2, 2014 at 3:45 PM
I want to use R.Net to call some R procedures mainly for plotting purposes.
I develop my code using Visual Studio 2012 (the application is .Net #4.5) (Standard MS .Net Compiler) on Windows 8.1 64bit

Which version of R should I install locally in order to have R.Net working?
  1. 32bit or 64bit?
  2. I saw lots of users reporting errors after installing versions other that R 3.0.2 (3.1.1 etc.) - is the proper version of R 3.0.2 32 bit ???
Sorry if this question has been asked before but I am not sure I these are up to date.

Regards,
Sebastian
Nov 2, 2014 at 4:04 PM
The latest versions of R, especially 3.0 and newer work just fine. You can use either 32bit or 64 bit. There is an issue with running R.Net under IIS/ASP.Net, but its a simple fix to resolve it.
Marked as answer by mix2ra on 11/2/2014 at 12:00 PM
Nov 2, 2014 at 4:19 PM
Edited Nov 2, 2014 at 7:00 PM
OK, so I should be able to install 3.1.2 64 bit and it will work. Is that correct?

Edit: Just installed R 3.1.2 (32 and 64 bit) and downloaded R.Net 1.5.16.30632 from nuget.
The Hello World Example is working.
Marked as answer by mix2ra on 11/2/2014 at 12:00 PM
Nov 3, 2014 at 5:30 PM
Remeber that 32-bit apps cannot access 64-bit DLL's and vice-versa.