RdotNet and R version 3.2.4

Mar 21, 2016 at 11:12 PM
Has anyone else upgraded to R-3.2.4revised-win yet?

I'm getting an error when trying to SetEnvironmentVariables

REngine.SetEnvironmentVariables();

rCurrentVersionString from registry is coming back as "3.2.4 revised"

return new Version(rCurrentVersionStringFromRegistry); throwing system.format exception.

Any suggestions on a fix?
Mar 22, 2016 at 4:32 PM
Edited Mar 22, 2016 at 4:32 PM
I've been struggling for a few hours trying to look for a solution, and feeling a bit happy when I finally found someone with the same problem :D

What is the version of R that I should use for now since it seems that it's not functioning well with 3.2.4-revised?
Mar 22, 2016 at 4:54 PM
I've confirmed it works with 3.2.3
Mar 22, 2016 at 5:34 PM
Thank you very much
Apr 15, 2016 at 10:37 AM
Edited Apr 15, 2016 at 10:41 AM
I also found the same issue with R-3.2.4revised-win. It works with 3.2.2 and I just tested with 3.2.5 (released 14/04/16) and it also works fine.

I noticed that the version string of R-3.2.4revised-win is "3.2.4 Revised" and I wonder if this is why RDotNet cannot detect it, because the string is not in the standard "x.y.z" format? Just a guess but seems possible since 3.2.3 and 3.2.5 both work.