This project is read-only.

R is waiting for 'yes' or 'no'. How to answer that?

Nov 29, 2016 at 5:58 AM
I am using R.NET v1.6.5. I ran following script and my C# application hung. Later I ran it in the RGUI console and found that R is actually waiting for me to enter 'yes' or 'no'. So, I guessed that the R session in C# application is also waiting for me to enter 'yes' or 'no' but I don't know how to interact with my R session to type in 'yes' or 'no'.
Is there a way to answer, if R is asking for some input from user when using R.NET in C# application?
Here is the script. Last line is asking for installing gbm R package. If you have gbm installed then you may not be able to replicate this issue.
str(Sonar[, 1:10])

inTraining <- createDataPartition(Sonar$Class, p = .75, list = FALSE)
training <- Sonar[ inTraining,]
testing  <- Sonar[-inTraining,]

fitControl <- trainControl( method = "repeatedcv",
                           number = 10,
                           repeats = 10)

gbmFit1 <- train(Class ~ ., data = training, 
                 method = "gbm", 
                 trControl = fitControl,
                 verbose = FALSE)